FIFE forums

Please login or register.

Login with username, password and session length
Advanced search  

News:

FIFE 0.4.0 has been released on 15th of January, 2017!

Author Topic: Build Error on OS X 10.8  (Read 5302 times)

hoffi

  • Newbie
  • Posts: 18
    • View Profile
Build Error on OS X 10.8
« on: August 08, 2012, 02:11:58 pm »

Hi,

tried to build FIFE using Scons on Mac OS X 10.8.
I have installed all required libraries.
But it seems like FIFE have a problem with my OpenAL-Version:

Code: [Select]
ld: warning: ignoring file /Library/Frameworks//OpenAL.framework/OpenAL, file was built for unsupported file format ( 0xfe 0xed 0xfa 0xce 0x 0 0x 0 0x 0 0x12 0x 0 0x 0 0x 0 0x 0 0x 0 0x 0 0x 0 0x 6 )
    which is not the architecture being linked (x86_64): /Library/Frameworks//OpenAL.framework/OpenAL
Undefined symbols for architecture x86_64:
  "_alBufferData", referenced from:
      FIFE::SoundClip::load()    in py_soundclip.os
      FIFE::SoundClip::getStream(unsigned int, unsigned int)in py_soundclip.os
  "_alDeleteBuffers", referenced from:
      FIFE::SoundClip::free()    in py_soundclip.os
      FIFE::SoundClip::quitStreaming(unsigned int)in py_soundclip.os
  "_alDeleteSources", referenced from:
      FIFE::SoundEmitter::~SoundEmitter()in py_soundemitter.os
      FIFE::SoundEmitter::~SoundEmitter()in py_soundemitter.os
  "_alGenBuffers", referenced from:
      FIFE::SoundClip::load()    in py_soundclip.os
      FIFE::SoundClip::beginStreaming()     in py_soundclip.os
  "_alGenSources", referenced from:
      FIFE::SoundEmitter::SoundEmitter(FIFE::SoundManager*, unsigned int)in py_soundemitter.os
[...]


I have tried to install OpenAL but the only thing i have found was the Installer for OSX here: http://connect.creativelabs.com/openal/Downloads/Forms/AllItems.aspx
SVN seems to be down

Install OpenAL with macports also don't works...

Hope you can help me :(
« Last Edit: August 08, 2012, 02:15:52 pm by hoffi »
Logged
Hackintosh - (Intel i7 - 2600k, ATI Radeon HD6870 1GB VRAM, 8 GB RAM, 128 GB OCZ Vertex4 SSD)
Mac OS X 10.8

hoffi

  • Newbie
  • Posts: 18
    • View Profile
Re: Build Error on OS X 10.8
« Reply #1 on: August 08, 2012, 02:19:33 pm »

Hm ok...

Somehow i got it now  ;D

I have copied OpenAL.framework from /System/Library/Frameworks to /Library/Frameworks
that helped could compile FIFE now  ;)
Logged
Hackintosh - (Intel i7 - 2600k, ATI Radeon HD6870 1GB VRAM, 8 GB RAM, 128 GB OCZ Vertex4 SSD)
Mac OS X 10.8

raymond

  • Newbie
  • Posts: 7
    • View Profile
Re: Build Error on OS X 10.8
« Reply #2 on: June 30, 2013, 03:36:48 am »

Please compile UH on http://www.unknown-horizons.org/download/sources/s-osx/ or howtos on http://www.unknown-horizons.org/download/os-x/ and provide a dmg package the developer.
« Last Edit: June 30, 2013, 03:38:54 am by raymond »
Logged