FIFE forums

Please login or register.

Login with username, password and session length
Advanced search  

News:

FIFE 0.4.0 has been released on 15th of January, 2017!

Author Topic: Ubuntu Engine Building Issue  (Read 181 times)

2000andrea

  • Newbie
  • Posts: 3
    • View Profile
Ubuntu Engine Building Issue
« on: October 16, 2017, 09:49:30 am »

Hi guys,
Ubuntu newbye here! I'm trying to build fifengine following the guide on the documentation (developers manual). I've arrived at the point of building the engine using cmake, and it is at this point that cmake gives me errors. It says that I have installed swig version 3.0.8, which i cannot use. I tried to remove the application (previously installed with "apt-get install"), and reinstall it via the tar.gz files found on the official site. I tried to use the 3.0.7 and the 3.0.6 versions, but both of them gives me the same error.
I really don't know where to put my hands and what to do.
Maybe I'm installing it in the wrong way? I started using Ubuntu "seriously" about a month ago, probably I'm missing something obvious regarding the installation process.
Logged

LinuxDonald

  • Newbie
  • Posts: 28
    • View Profile
    • My Blog (German)
Re: Ubuntu Engine Building Issue
« Reply #1 on: October 16, 2017, 12:27:35 pm »

First it would be good to know what Ubuntu version do you use? Because i have with Ubuntu 17.04 no problems.
Logged

2000andrea

  • Newbie
  • Posts: 3
    • View Profile
Re: Ubuntu Engine Building Issue
« Reply #2 on: October 17, 2017, 10:35:54 am »

First it would be good to know what Ubuntu version do you use? Because i have with Ubuntu 17.04 no problems.

I have Ubuntu 16.04 LTS.
Few moments ago I tried with Swig 2.0, but it gives the same error. In case these info matter, I have aliased the name python to refer to the (newest) Python 3.4, and I have cmake 3.4.
Logged

LinuxDonald

  • Newbie
  • Posts: 28
    • View Profile
    • My Blog (German)
Re: Ubuntu Engine Building Issue
« Reply #3 on: October 17, 2017, 12:50:26 pm »

You need to install an newer swig version. Swig 3.0.8 is broken with fife.
You could use: https://packages.ubuntu.com/zesty/swig its Swig 3.0.10

And an error log would be nice too.
Logged

2000andrea

  • Newbie
  • Posts: 3
    • View Profile
Re: Ubuntu Engine Building Issue
« Reply #4 on: October 18, 2017, 02:34:36 pm »

Thank you very much, that solved the problem!
If I may ask here, without creating another topic, how can I use codeblocks/visual studio code? I searched in the build files the .cbp file/solution file, but I have not found them. Perhaps I have to create them with a command to cmake?


EDIT: Nevermind, just figured it out myself.
« Last Edit: October 18, 2017, 02:56:23 pm by 2000andrea »
Logged