FIFE forums

Please login or register.

Login with username, password and session length
Advanced search  

News:

FIFE 0.4.0 has been released on 15th of January, 2017!

Author Topic: Trouble with CMake and Fifechan in Windows  (Read 2555 times)

Niektory

  • Newbie
  • Posts: 29
    • View Profile
Trouble with CMake and Fifechan in Windows
« on: April 15, 2013, 09:27:44 am »

I'm trying to build Fifechan in Windows but I can't get CMake to cooperate.
If I try MinGW Makefiles it complains that it can't find the RC compiler.
If I pick Visual Studio 9 2008 it gets further but it complains about SDL_image.
I've tried setting the relevant variables but it doesn't seem to work...
I've never used CMake before so I might be doing something stupid.
Any ideas?

EDIT: Attachments aren't visible if you're not logged in...
http://niektory.republika.pl/cmake2.png
http://niektory.republika.pl/cmake1.png
« Last Edit: April 15, 2013, 03:19:38 pm by Niektory »
Logged

flutschfinger

  • Newbie
  • Posts: 14
    • View Profile
Re: Trouble with CMake and Fifechan in Windows
« Reply #1 on: April 15, 2013, 04:38:38 pm »

To help others fix issues with fifechan:
In general its recommended to use these SDK http://forums.fifengine.net/index.php?topic=571.0, only if there are special reasons you should try to build fifechan on your own.
Logged

prock

  • Developer
  • Full Member
  • *
  • Posts: 236
    • View Profile
Re: Trouble with CMake and Fifechan in Windows
« Reply #2 on: April 29, 2013, 09:50:56 am »

We should probably add this to the fifechan issue tracker.  Ideally we should be able to compile fifechan with cmake on windows.
Logged

Niektory

  • Newbie
  • Posts: 29
    • View Profile
Re: Trouble with CMake and Fifechan in Windows
« Reply #3 on: March 28, 2014, 06:03:04 am »

I've attached a screenshot showing how to set CMake variables to point to SDL libraries. They're the 5 bottommost ones. You need to check "Advanced" to show them all. After setting them hit "Configure" and it should work.
I didn't have trouble with MinGW this time around. After installing the latest version (with mingw-get) to the default location it was detected automatically by CMake.

http://niektory.republika.pl/fifechan2.png
« Last Edit: May 02, 2015, 08:30:54 am by Niektory »
Logged