FIFE forums

General Category => Help and troubleshooting => Topic started by: Jim on July 04, 2014, 07:34:07 am

Title: Another trouble building fife in win 8 using mingw thread
Post by: Jim on July 04, 2014, 07:34:07 am
Hi, I've been trying for hours to build the latest version of fife, and so far no success. When I use mingw in combination with the April 2012 devkit, I get the same "fifechan.hpp no such file or directory" error as the guy in this thread (, and if I use the November 2012 prerelease devkit I get an error I can't find anywhere on this forum:

Code: [Select]
scons: Entering directory `C:\FIFE'
scons: Reading SConscript files ...
Checking for tinyxml (using pkg-config)...(cached) no
Checking for tinyxml (using tinyxml-config)... (cached) no
Checking for C++ library tinyxml... (cached) no
Warning: System version of tinyxml not found, using local version as fallback
Building RELEASE binaries...
scons: done reading SConscript files.
scons: Building targets ...
swig -o build\engine\release\swigwrappers\python\ -outdir "engin
e\python\fife" -Ibuild\engine\release\core -Iengine\core -python -c++ -w511 engi
g++ -o build\engine\release\swigwrappers\python\py_fifechan_wrap.o -c -O2 -Wall
ild\win32\includes\libogg -Ibuild\win32\includes\openal -Ibuild\win32\includes\s
dl_image -Ibuild\win32\includes\zlib -Ibuild\win32\includes\boost_1_47_0 -Ibuild
\win32\includes\libvorbis -Ibuild\win32\includes\libpng -Ibuild\win32\includes\s
dl_ttf -Ibuild\win32\includes\sdl -Ibuild\win32\includes\python27 -Ibuild\win32\
includes\unittest++\src -Ibuild\win32\includes\libfifechan -Iengine\core build\e
build\engine\release\swigwrappers\python\ In function 'PyObject
* _wrap_Widget_isSetVisible(PyObject*, PyObject*)':
build\engine\release\swigwrappers\python\ error: 'const
 class fcn::Widget' has no member named 'isSetVisible'
scons: *** [build\engine\release\swigwrappers\python\py_fifechan_wrap.o] Error 1

scons: building terminated because of errors.
15 File(s) copied

I tried adding all the includes and applications in the Environment PATH, but didn't do anything (most likely because I'm an idiot). Problem, like with most people seems to be fifechan in both cases, but I haven't a clue what to begin doing about it. Can anybody help me out?

I also tried building with vs9 and the april 2012 devkit but that didn't achieve much either.
Title: Re: Another trouble building fife in win 8 using mingw thread
Post by: Niektory on July 05, 2014, 05:23:10 am
I think to build the current FIFE with Fifechan you also need the current Fifechan, and the one in the devkit is too old. Which means, you need to build Fifechan yourself first.

We could use another release, it's been a while since the last one...
Title: Re: Another trouble building fife in win 8 using mingw thread
Post by: Jim on July 05, 2014, 07:25:40 am
Thanks man, I'll give it a try based on that thread of yours. Another release would be sweet, yeah, fitting too given that it's 4.0 now I think.